• 0
lolleur13720

probleme de lancement screen .sh debian 8

Question

Salut à tous !

Je viens de mettre mon emu sur mon VPS qui est sous Debian 8, j'ai suivi le tuto qu'il y a sur le forum,

mais au moment d'exécuter ma commande screen ./start.sh la console me dit Cannot exec './start.sh': No sush file or directory. (voir screen)

Je ne vois pas d'où ça peut venir car  mon fichier bash est bien dans le repertoire ou j'exécute la commande. 

 

Est ce que quelqu'un peut m'aider svp ?

 

Merci d'avance.

 

Screen :

 1547239757-screen.png

1547239835-screen2.png

 

Partager ce message


Lien à poster
Partager sur d’autres sites

14 réponses à cette question

Recommended Posts

  • 0

T'es aller jusqu'au dossier : 

cd /home/emu/game

Puis  ./start.sh

 ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 1 heure , deciibel a déclaré:

T'es aller jusqu'au dossier : 

cd /home/emu/game

Puis  ./start.sh

 ?

oui oui et ça me sort cette erreur 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Quand t'es dans 

cd /home/emu/game

Fait un 

ls

Permettra de voir si ta bien ton start config  jiva.jar  

Dans ton start y'a quoi aussi ? Si tu ta suivis un tuto tu a bien penser a mettre dans une ligne la je me rappel plus comme ça la a mettre en tout cas  jiva.jar a la place de game.jar certainement qui devais y avoir.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 23 minutes, deciibel a déclaré:

Quand t'es dans 

cd /home/emu/game

Fait un 

ls

Permettra de voir si ta bien ton start config  jiva.jar  

Dans ton start y'a quoi aussi ? Si tu ta suivis un tuto tu a bien penser a mettre dans une ligne la je me rappel plus comme ça la a mettre en tout cas  jiva.jar a la place de game.jar certainement qui devais y avoir.

oui ya tout de bon c'est pas la premiere fois que je fais un serveur mais ça c'est la premiere fois :/

dans mon cd /home/emu/game ou login j'ai le JAR, la config et lee start.sh

voici les screen de mon bash login et game qui sont bon ^^

game : 

1547250042-game.png

 

Login :

1547250063-login.png

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

ajoute moi sur discord si tu veux ça sera plus simple :D 

AnthoR#3856

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

fait sudo chmod +x start.sh

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 50 minutes, Dysta a déclaré:

fait sudo chmod +x start.sh

salut merci pour ta réponse, j'ai déjà effectué la commande et tout les fichiers de l'ému sont en 7777 donc les droits maximum :/

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Un petit cd /home/emu/game avant ;) 
Oublies pas de chmod +x start.sh ( pour avoir les droits dessus ) et quand tu lances le realm si tu le fais aussi tu fais CTRL A puis CTRL D et tu pourras lancer de nouveau cd /home/emu/... et puis le start.sh du login sans relancer une nouvelle fenêtre SSH :) 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 52 minutes, Dofux a déclaré:

Un petit cd /home/emu/game avant ;) 
Oublies pas de chmod +x start.sh ( pour avoir les droits dessus ) et quand tu lances le realm si tu le fais aussi tu fais CTRL A puis CTRL D et tu pourras lancer de nouveau cd /home/emu/... et puis le start.sh du login sans relancer une nouvelle fenêtre SSH :) 

oui merci je connais tout ça j'en suis pas a mon premier serveur ^^

Juste que cette erreur ne met jamais arrivé :/

comme dit plus haut tout mes fichiers serveur ont tout les droits (7777) et je vais bien dans le repertoire du game et du login pour exécuter mon bash (screen ./login ou game.sh)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 42 minutes, lolleur13720 a déclaré:

oui merci je connais tout ça j'en suis pas a mon premier serveur ^^

Juste que cette erreur ne met jamais arrivé :/

comme dit plus haut tout mes fichiers serveur ont tout les droits (7777) et je vais bien dans le repertoire du game et du login pour exécuter mon bash (screen ./login ou game.sh)

Essayes : 

 

#!/bin/sh
while [ 1 ]
do
java -jar -Xmx1000m -Xms1000m game.jar
echo `date`": Serveur crash!!!"
sleep 5
done

 

Et descend petit a petit le xm x et s au nécéssaire

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 1 heure , Dofux a déclaré:

Essayes : 

 

#!/bin/sh
while [ 1 ]
do
java -jar -Xmx1000m -Xms1000m game.jar
echo `date`": Serveur crash!!!"
sleep 5
done

 

Et descend petit a petit le xm x et s au nécéssaire

Merci pour ta réponse 

j'ai essayer de faire ce que tu ma dit je suis descendu jusqu’à 500 en xmx et s mais ça n'a rien changé j'ai toujours l'erreur :/

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Fait ça :

Connnecte toi

screen -S game

cd home/emu/game

sh ./start.sh

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Résolus !

Merci à tous pour vos réponse :) 

La solution : J'ai tout simplement créer les fichier .sh avec les commandes (screen -S login et game) puis j'ai mis le script avec nano et après mis les autorisations et voila :)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Ouai faut jouer avec les screens

  • sudo -i
  • screen -ls (pour lister les screens)
  • screen -s nomDuScreen (pour créer un screen)
  • screen -r nomDuScreen (pour se rattacher au screen)
  • CTRL + A + D ((pour se détacher d'un screen)
  • CTRL + C (pour couper le programme lancé sur le screen)

normalement avec ça tu fais tout

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant